Cancel
Online Tabletop Roleplaying Game BETA

Latest Posts

Main Forums

Fabletop

Support

Report a Bug

Cannot register

whiteman Jan '16
I tried to get my friends to register into fabletop and join my game but after filling out the information the page just refreshes and nothing happens. When they try to log in with the information submitted they are unable to login. I tried to make a new account myself but it still did not work, and also tried to use different browsers. Im using windows 10 and the latest version of google chrome.

My browser version is: (do not change)
Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36
duskwolf Feb '16
This just happened with my friend as well. She tried multiple emails, and usernames. After trying to log in, the log in just says bad user name and password.
woslla Mar '17
Same here
erstwhile Mar '17
Bunch of friends really want to do a session with me but this bug is in the way, so yeah. same here
oman1666 Mar '17  /  edited Mar '17
Update: 2 minutes after posting this, Frost informed that 'sign up' is back on

Please log in to add a comment.